Browsers | Pluckeye

This page explains which Internet browsers Pluck supports.

Pluck works well in browsers that are based on Chromium 46 or newer. This includes Chrome, Brave, Vivaldi, and many more. Pluckeye v0.99.70 also works with some versions of Firefox. Finally, Pluckeye v0.99.60 and below might work with old Firefox forks such as Pale Moon and Waterfox, but such browsers are not tested and support is not guaranteed.

Firefox

Firefox is (so far) not supported in Pluck 1.0 and above.

Jon wishes it were otherwise, but there is a critical feature missing from Firefox that makes supporting it “well” impossible. Should this part of Firefox ever be changed, it is quite likely Pluckeye will once again support Firefox. Until then, Firefox loyalists may have to choose between Firefox and Pluckeye. Choose wisely.

Jon himself used Firefox for many years, but finally switched to Chrome and Brave because of the unaddressed deficiency.

Firefox 74

Firefox v74+ is not supported out of the box.

If you want a supported setup, you can use Chrome, Brave, Pale Moon, or Vivaldi instead.

If you install Pluckeye while using Firefox 73, and then upgrade to Firefox 74, Firefox 74 should continue to work with Pluckeye.

If you want to use Firefox 74 and you haven’t got Firefox 73, you can install the Firefox addon below, but you may have to manually uninstall the addon at a future date if and when Pluckeye does start supporting Firefox 74+. Don’t forget this!

Addon

For users of modern Firefox:

For users of Pale Moon or Waterfox: